Windows 10 Icons Not Showing, Preview Not Working

I had a weird issue with Windows 10 today. All of a sudden, my icons weren’t displaying correctly. When I had the Preview Pane on, nothing was displayed. Even more bizarre, The Layout area of the View pane in Windows Explorer, had all the icons disabled.

Turned out I had a corrupted icon cache. To fix this for yourself, first open up a copy of Windows Explorer (or My Computer or whatever you wish to call it).

Go to the View tab, and make sure the Hidden Items is checked on.

SNAGHTML17f6c4

Now navigate to C:\Users\(User Name)\AppData\Local, where of course (User Name) is replaced with your user name.

Find the file IconCache.db, right click and delete it. Yes, that’s right, delete it. It’s OK, it won’t hurt.

To be really thorough, you could now head to the Recycle Bin, and clean it out, or at least open the Recycle Bin and remove the IconCache.db file. However you could skip this step if your the nervous type.

OK, that done, restart your computer.

When you return to the folder, such as your Pictures folder, Windows will start rebuilding the icon cache automatically, and you should now see your icons working again, and the preview pane should also now be functional.

Standard disclaimer, no warranty or guarantees provided, this is what worked to me (and to be honest I’m making it a blog post to remind me should it happen again). This may or may not work for you, but as the icon cache will automatically build itself it’s pretty safe to try.  Good luck!

Advertisements